Bienvenue sur Le site des utilisateurs francophones actuels et futurs d'AmigaOS 4.x
Recherche
17 visiteur(s) et 0 membre(s) en ligne.
 
 
    Annonces Google

    Petites Annonces

il y a annonces
    IRC

Serveur : irc.portlane.se
Canal : #AmigaNG
    Liens

Toutes les informations sur :
  • Amiga OS 4:
    AmigaOS.net
  • Logiciels pour OS4 :
    OS4depot
  • Matériel Amiga :
    ACube Systems
  • Magazine papier :
    AmigaPower
  • Magazine en ligne :
    Obligement
  •     Activité du Site

    Pages vues depuis 25/07/2007 : 105 829
    • Nb. de Membres : 183
    • Nb. d'articles : 1 118
    • Nb. de Forums : 18
    • Nb. de Sujets : 17
    • Nb. de Critiques : 22

    Top 10  Statistiques

      
    Modéré par : K-L Creols Elwood 
    Index du Forum > > Création-Développement > > Wazp3D 57
    2 pages [ 1 | 2 ]
    AuteurWazp3D 57
    thellier
    862      

    thellier
      Posté : 23-04-2018 15:11

    Salut les amigaïstes

    C'est un truc sur lequel je travaille depuis quelques semaines

    Et comme ça commence à marcher voici une première image: soyez attentifs y a une nouveauté

    http://thellier.free.fr/Wazp3D-57.JPG

    Mais vous emballez pas ça commence juste à marcher...

    Alain







    Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig

      Afficher le profil de thellierProfil  Imprimer ce commentaireImprimer
    CrashMidnick
    203     

    CrashMidnick
      Posté : 23-04-2018 15:32

    Intéressant tout ça ! Ca fonctionnera donc sur tout support ? (UAE, MorphOS, classic (même si inutile)...)


    Pegasos 2 1Ghz/Radeon 9000 PRO/SB live/USB2/OS4.1 FE
    Gamme complète des classic 68K/PPC

      Afficher le profil de CrashMidnickProfil  Imprimer ce commentaireImprimer
    sinisrus
    3047       

    sinisrus
      Posté : 23-04-2018 17:34

    wazp3d > redirection vers warp3d nova ??


    --
    Coin coin... amitheme.amiga-ng.org
    Sam460 1,15Ghz - OS4.1FE - Radeon4650 1Go - 2Go de ram

      Afficher le profil de sinisrusProfil  Ouvrir le site web de sinisruswww  Imprimer ce commentaireImprimer
    thellier
    862      

    thellier
      Posté : 23-04-2018 20:56

    Wazp3D fonctionne déjà sous WinUAE,Aros,Morphos et OS4.
    Sous OS4 il y avait un rendu soft et via la composition pour la 2D
    Et là j'y rajoute un rendu via Nova donc en hard...

    Pour le moment c'est plus lent que le vrai Warp3D donc c'est pas top

    Tout n'est pas implémenté mais y a notamment le modulate (éclairage) + le texturing. Comme on le vois sur le grab des trucs simples comme les couleurs "plates" (pas en dégradée) sont pas encore implémentées (les ronds des lampes)


    Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig

      Afficher le profil de thellierProfil  Imprimer ce commentaireImprimer
    K-L
    4865       

    K-L
      Posté : 23-04-2018 21:53

    Sympa ! Cela permettrait donc de se passer de Warp3D SI ?

    --
    AmigaONE X1000/1,8 Ghz (A-Eon), Radeon HD 7770, 2 Go de Ram et OS4.1 FE
    Sam440ep/733Mhz (ACube), Radeon M9, 512Mo de RAM et OS4.1 FE

      Afficher le profil de K-LProfil    Imprimer ce commentaireImprimer
    sinisrus
    3047       

    sinisrus
      Posté : 23-04-2018 23:33

    Je pense plutôt que ça va permettre d'utiliser tous les softs warp3d avec warps3d nova donc plus rapide???


    --
    Coin coin... amitheme.amiga-ng.org
    Sam460 1,15Ghz - OS4.1FE - Radeon4650 1Go - 2Go de ram

      Afficher le profil de sinisrusProfil  Ouvrir le site web de sinisruswww  Imprimer ce commentaireImprimer
    thellier
    862      

    thellier
      Posté : 24-04-2018 11:08

    >permettrait donc de se passer de Warp3D SI ?

    Effectivement ce serai un effet collatéral

    > avec warps3d nova donc plus rapide???

    C'étais l'idée mais là c'est plutôt bien plus lent avec une cause inconnue pour l'instant

    Donc l'intérêt est limité à ce stade :-/






    Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig

      Afficher le profil de thellierProfil  Imprimer ce commentaireImprimer
    CrashMidnick
    203     

    CrashMidnick
      Posté : 24-04-2018 12:31

    Ha oui je n'avais pas fait gaffe à Nova, je regardais plus ton image de fond, va savoir pourquoi...

    Bon courage pour la suite, tu vas finir par trouver ce qui cloche ;)


    Pegasos 2 1Ghz/Radeon 9000 PRO/SB live/USB2/OS4.1 FE
    Gamme complète des classic 68K/PPC

      Afficher le profil de CrashMidnickProfil  Imprimer ce commentaireImprimer
    thellier
    862      

    thellier
      Posté : 18-05-2018 10:53

    Retransmission de mails pour info:
    >De : HunoPPC Free
    >Je viens vers toi pour que tu me transmette ta nouvelle version de wazp3d que je bosse sur la version nova dans mon interface minigl, ce weekend on est chez lio pour faire un mini rassemblement


    J’essaye de bosser sur des trucs puis je finis rien :
    • PatchCompositeTags comme une .library
    • GMAP et Hydorah (marche mais trop de bugs)
    • Cow3D avec un renderer special 68k pour la Vampire
    • NovaOnda avec les sources

    Pour Wazp3D 57 avec rendu Nova c’est encore à un stade très partiel (cad que beaucoup de choses sont pas du tout implémentées et je le sais) néanmoins ce qui existe marche…. même si la vitesse est bien inférieure à celle du vrai WaRp3D
     Y a une bug mineure sur la couleur d’éclairage (genre BGR vs RGB)
    Pour l’instant je n’ajoute aucune de ces fonctionnalités manquantes (perspective, fog, couleurs plates, points, etc..) et essaye juste de le rendre plus rapide : je gagne petit à petit des fps mais arriver à doubler la vitesse va être un vrai challenge : il faudra certainement modifier une bonne part de comment Wazp3D lit/stocke les points mais ce sera profitable à toutes les versions

    D’autre part  WaZp3D semble désormais complétement bogué au niveau de Wazp3D-Prefs. Pour la faire courte : l’ouverture de Wazp3D-Prefs remet les valeurs par défaut à tous les coups (cad la .library semble faire un LibInit à chaque ouverture)  parfois aussi on perd la config au prochain relancement d’un programme qui utilisait Nova jusqu’à maintenant

    Bref je te donne Wazp3D 57 comme POC à montrer aux gens mais c’est pas hyper profitable : Cow3D 68 FPS sur Sam460
    A vrai dire Wazp3D/Nova ne m’intéresse pas vraiment = le vrai objectif sera Microbe3D avec rendu Nova

    Amuse toi bien

    Alain



    Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig

      Afficher le profil de thellierProfil  Imprimer ce commentaireImprimer
    thellier
    862      

    thellier
      Posté : 07-06-2018 11:29

    Bon ça progresse

    Cow3D atteint désormais 97 ou 105 fps selon que le champ couleur est en floats ou rgba32

    (rappel: 142 fps avec un vrai WaRp3D)

    J'avais même cru atteindre 119 fps ... mais en fait je ne lisais plus ce champ (bug) la vitesse de lecture/écritures des points 3D semblent déterminantes (bus lent?)

    >bug mineure sur la couleur d’éclairage:

    corrigée mais à vérifier sur d'autres progs...

    >bogué au niveau de Wazp3D-Prefs

    nan pas de bug ... en fait je suis idiot: j'avais un Wazp3D.cfg dans le répertoire de Wazp3D-Prefs ce qu'il faut jamais faire bien entendu

    >fonctionnalités manquantes (perspective, fog, couleurs plates, points)

    Implémentées et désormais seules les couleurs plates buggent et y manque le multi-texturing dans Microbe3D

    Désormais Cow3D,Microbe3D et Quake3 marchent (sur os4 les versions 68k et ppc )

    Quake3 est hyper lent (mais beau) alors que mon Wazp3D est désormais relativement rapide (>500 000 triangles/seconde) = cause inconnue

    http://thellier.free.fr/Wazp3D-57-quake3.jpg

    Alain



    Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig

      Afficher le profil de thellierProfil  Imprimer ce commentaireImprimer
    Aller à la page : [ 1 | 2 ]
    Sauter à :


    Tous les Logos et Marques sont déposés, les commentaires sont sous la responsabilité de ceux qui les ont publiés. AmigaOS 4.x est (c) Hyperion Entertainment

    Conception graphique du thème : PowerMetal, codage : Alexandre Balaban
    Certaines images sont © Martin \"Mason\" Mertz

    Temps : 1537279762.4986 seconde(s)